I use Snips addon on which is updated to 0.5.4 recently. The hotword detection always work well but Snips then has an error on playing respond sound and no sound will be output afterwards. The error messages are listed below. By the way, I have not seen this error when using Snips 0.4.9. Does anyone has idea to fix it?

Expression ‘ret’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 1736
Expression ‘AlsaOpen( &alsaApi->baseHostApiRep, params, streamDir, &self->pcm )’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 1904
Expression ‘PaAlsaStreamComponent_Initialize( &self->playback, alsaApi, outParams, StreamDirection_Out, NULL != callback )’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 2175
Expression ‘PaAlsaStream_Initialize( stream, alsaHostApi, inputParameters, outputParameters, sampleRate, framesPerBuffer, callback, streamFlags, userData )’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 2840
[21:07:36.883403] ERROR:snips_audio_server_hermes: an error occured while playing name: “/usr/share/snips/dialogue/sound/end_of_input.wav”: Error in audio driver: ‘Device unavailable’


I too am getting this exact error having tried snips on both and with a regular install on Raspbian Lite.

It seems like it is an issue with 0.5.4 release. I am going to try and use an earlier version and see if it works.


I ran into the container and tried to play wav file. “Device or resource busy” was shown as expected. Then I killed PID of /usr/bin/snips-audio-server. The sound device was released and I can play wav as many times as I want. However, if I try to start the talk or send tts MQTT topics to Snips, the sound device went die because of this error… I cannot find this problem in 0.4.9 and 0.5.3. So I think snips-auido-server in 0.5.4 is very likely the root cause.


You can test sending wav files directly to the audio server, look here for some more info.