[Solved] Microphone Not Found


#1

Hi all,

I am currently trying to use Snips in Home Assistant following this tutorial :

My Microphone seems to be correctly set up and recognized becaus I am able to record myself with “arecord -f cd” and listen with “aplay”.
However when I try to run the command “snips” I get :

> Running Snips
> No microphone found, make sure you connect a microphone to your Raspberry Pi and it is visible with 'arecord -l'

Here is the output of “arecord -l”

**** Liste des Périphériques Matériels CAPTURE ****
carte 1: USB [Jabra SPEAK 410 USB], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0

Did anybody here had similar issue? Do you have an idea why snips does not find my microphone but arecord does?


#2

Hello Sancho,

It’s surprising to me because we have the jabra 510 at our office and we didn’t encounter your issue.
The first thing you can check is the presence of the .asoundrc file in your pi’s home folder. It should look like this :

pcm.!default {
  type asym
   playback.pcm {
     type plug
     slave.pcm "hw:0,0"
   }
   capture.pcm {
     type plug
     slave.pcm "hw:1,0"
   }
}

Alternatively, you can force our audio server into recognizing your mic but adding the argument

-e 'SNIPS_AUDIO_SERVER_MQTT_ARGS=--mike="Jabra SPEAK 410 USB: USB Audio (hw:1,0)"'

The complete docker command :

docker run -t --rm --name snips --privileged -p 9898:1883 -v /home/pi/.asoundrc:/root/.asoundrc -v /opt/snips/config:/opt/snips/config -e 'SNIPS_AUDIO_SERVER_MQTT_ARGS=--mike="Jabra SPEAK 410 USB: USB Audio (hw:1,0)"' -v /dev/snd:/dev/snd snipsdocker/platform

Cheers,


#3

Actually we found the issue. You can ignore what I said. We install a small script at /usr/bin/snips The problem comes from the test we run at the launch of snips. We do a arecord -l | grep card & it fails on non english raspis.

To fix the issue, in usr/bin/snips file, remove the line :
(arecord -l | grep card > /dev/null) || (echo "No microphone found, make sure you connect a microphone to your Raspberry Pi and it is visible with 'arecord -l'" >&2 ; exit 1)

It’s with your report that we discovered this issue, thanks! We’ll update our installation script accordingly.
Happy testing,


#4

Thank you Charles, it works like a charm !
Indeed it is a bit exotic to have configured the raspi in french…
I can’t wait to start using my home assistant with the voice without sending everything I say to Google !


#5

Hi,

I’ m Setting up snips on a pi3 and have a question. I‘m using raspberry 3b justboom amp and as a microphone I have a jabra 510 MS. Everything works really fine but I can’t connect the 510 via Bluetooth and I only wanna use the microphone not the speaker of the 510. Can sb. help me?

Thx in advance

Philipp


#6

Hi, Nobody can help me?