Snips is sensitive!


#1

My biggest problem with snips is trigger word sensitivity. Basically any loud conversation around snips triggers activation and feed back - “sorry I don’t know what you mean”. What is really funny is that I speak 4 different languages and basically any conversation between me and someone else in language snips shouldn’t understand still activates assistant.

Is there any way to adjust sensitivity ?

Thanks.


#2

Hey @R27,

You can play with the SENSITIVITY parameter for the hotword detection.
To do so, edit your /usr/bin/snips file like so :

docker run [...] -e SNIPS_HOTWORD_MQTT_ARGS="--sensitivity=0.5" [...] snipsdocker/platform:arm-latest

You can fiddle around different values and choose which one suits you best.
Also, you can play with the recording level of your microphone, by issuing : alsamixer.

Cheers


#3

error: Found argument ‘–sensitivity’ which wasn’t expected, or isn’t valid in this context

USAGE:
snips-hotword mqtt [OPTIONS]